5 Comandos do Cisco IOS que todo Network Admin deveria saber

Tempo de leitura: 7 minutos

Cisco IOSOlá aluno, amigo ou fã da DlteC! Hoje vou falar para você sobre alguns comandos indispensáveis para quem possui dispositivos com Cisco IOS em sua rede, sejam roteadores ou switches.

Essa lista traz cinco comandos do Cisco IOS essenciais para que um administrador de redes que tem equipamentos Cisco em sua rede de forma do menos importante para o mais, ou seja, vamos começar pelo quinto lugar até chegar ao mais importante.

5 – show interfaces

É importante saber o que interfaces estão no seu roteador, as estatísticas mais importantes sobre essas interfaces e se elas são para UP ou DOWN (ativas ou inativas).

O comando do Cisco IOS show interfaces é um comando muito detalhado que fornece uma grande quantidade de informações.

Você pode ter que vasculhar na saída do comando para encontrar o que você está procurando, pois muitas informações das interfaces são mostradas.

Por exemplo: erros em uma interface, utilização da banda, velocidade de interface, etc.

Esse comando pode ser abreviado como sh int. Veja abaixo exemplo do comando para visualizar os dados da interface fast 0/0.

DlteC-FW-GW#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up 
 Hardware is Gt96k FE, address is 001e.130b.1aee (bia 001e.130b.1aee)
 Description: $FW_OUTSIDE$
 Internet address is 192.168.10.2/24
 MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec, 
 reliability 255/255, txload 1/255, rxload 9/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 100Mb/s, 100BaseTX/FX
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:08, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 3828000 bits/sec, 321 packets/sec
 5 minute output rate 91000 bits/sec, 175 packets/sec
 5050025 packets input, 2166463710 bytes
 Received 73 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
 0 watchdog
 0 input packets with dribble condition detected
 3343492 packets output, 395111853 bytes, 0 underruns
 0 output errors, 0 collisions, 2 interface resets
 0 unknown protocol drops
 0 babbles, 0 late collision, 0 deferred
 0 lost carrier, 0 no carrier
 0 output buffer failures, 0 output buffers swapped out
DlteC-FW-GW#

Em outro post que fizemos anteriormente mostramos mais explicações sobre esse comando e como utilizá-lo no dia a dia, confira que pode te ajudar no dia a dia: clique aqui para ver o artigo.

4 – copy running-config startup-config

Os roteadores e switches Cisco não gravam automaticamente configurações ou alterações realizadas em uma memória permanente, portanto se você alterar algo na config e não salvar o roteador perde toda a informação caso reinicializado ou desligado.

O comando do Cisco IOS copy running-config startup-config salva a configuração atual na memória NVRAM que é permanente e usada para armazenar a configuração de inicialização dos roteadores e switches com Cisco IOS.

Ourtra forma de escrever o mesmo comando é utilizando o wr (write memory), copy run start ou copy r s (em meus cursos chamo às vezes de copy Rio Grande do Sul – RS). Veja exemplo abaixo.

R1#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
R1#

3 – show ip route

Comando do Cisco IOS utilizado para verificar as entradas de roteamento em roteadores e switches layer-3 com o roteamento IP habilitado.

Sem dúvida esse comando do Cisco IOS é fundamental, pois após configurada a parte de roteamento é aqui que o administrador de redes pode validar se o roteador aprendeu as rotas necessárias para encaminhar os pacotes através da rede.

Veja exemplo abaixo.

DlteC-FW-GW#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.10.1 to network 0.0.0.0
C 192.168.10.0/24 is directly connected, FastEthernet0/0
 10.0.0.0/32 is subnetted, 1 subnets
C 10.10.10.10 is directly connected, Loopback1
C 192.168.1.0/24 is directly connected, FastEthernet0/1.10
C 192.168.2.0/24 is directly connected, FastEthernet0/1.30
S* 0.0.0.0/0 [1/0] via 192.168.10.1
DlteC-FW-GW#

Você pode abreviar esse comando do Cisco IOS com sh ip ro.

2 – show ip interface brief

Esse comando do Cisco IOS é um resumo do comando “show ip interface“, trazendo apenas informações sobre as interfaces, o endereço configurado e se elas estão UP ou DOWN.

Ele é muito útil para visualização de um resumo das interfaces e seus respectivos endereços porque fica bem mais simples de verificar as informações que no show interface.

Veja exemplo abaixo.

R1#show ip interface brief 
Interface IP-Address OK? Method Status Protocol
Embedded-Service-Engine0/0 unassigned YES NVRAM administratively down down 
GigabitEthernet0/0 192.168.1.225 YES DHCP up up 
GigabitEthernet0/1 unassigned YES NVRAM administratively down down 
Serial0/0/0 unassigned YES NVRAM administratively down down 
R1#

Você pode abreviar esse comando do Cisco IOS com sh ip int bri.

1 – show running-config

O mais importante comando do Cisco IOS para o administrador com certeza é o show running-config, porém nem sempre simples de ser interpretado.

Esse comando do Cisco IOS mostra a configuração do roteador ou switch, ou seja, o endereço IP, interfaces, senhas, protocolo de roteamento e tudo mais que esteja configurado é visto nesse comando.

Veja exemplo abaixo.

R1#show running-config 
Building configuration...
Current configuration : 2138 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot system flash0:c1900-universalk9-mz.SPA.154-3.M2.bin
boot system flash0:c1900-universalk9-mz.SPA.152-1.T1.bin
boot system flash0:c1900-universalk9-mz.SPA.150-1.M4.bin
boot-end-marker
!
!
enable secret 5 $1$s4x6$7av3JRu903sVvE4AOcHCR.
!
aaa new-model
!
!
aaa authentication login default local enable
aaa authorization exec default local 
!
!
!
!
!
aaa session-id common
memory-size iomem 10
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip vrf Cust
!
!
!
!
ip domain name dltec.com.br
ip name-server 192.168.10.1
ip name-server 8.8.8.8
ip cef
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
cts logging verbose
!
!
license udi pid CISCO1941/K9 sn FTX150800UX
license boot module c1900 technology-package securityk9
license boot module c1900 technology-package datak9
! 
!
username dltec privilege 15 secret 5 $1$mHq2$WYyum20RMizeWim4F6RDI/
!
redundancy
!
!
!
!
!
ip ftp username geral
ip ftp password doBrasil
! 
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip dhcp client default-router distance 1
 ip dhcp client update dns server both
 ip address dhcp
 duplex auto
 speed auto
 ipv6 address dhcp
 ipv6 enable
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
!
! 
router eigrp 100
 !
 address-family ipv4 vrf Cust 
 exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip flow-export version 9
!
!
!
!
!
!
!
ipv6 access-list cisco
 permit tcp host 2001:100:0:4::30 any eq 22
 permit tcp host 2001:100:0:4::30 any eq telnet
!
control-plane
! 
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 ipv6 access-class cisco in
 transport input telnet ssh
line vty 5 15
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end
R1#

Podemos abreviar o comando como sh ru ou wr t.

Conclusão

É bem difícil de escolher 5 dentre as centenas de comandos que estão disponíveis no Cisco IOS, porém concordo com o artigo sobre os essenciais.

E você concorda com essa lista?

Acha que algum comando do Cisco IOS está faltando ou não é tão importante assim e deveria ser retirado dessa listagem?

Deixe seu comentário no final da página, aguardo ansiosamente suas dúvidas e opiniões!

Espero que você tenha gostado e até a próxima!

PS: os comandos básicos, sejam eles para trobleshooting (resolução de problemas) ou configuração são tratados em nosso curso CCNA CCENT, esse curso traz desde o básico até o intermediário das configurações do Cisco IOS para roteadores e switches, se você é iniciante é por aí que deve começar sua caminhada!

Prof Marcelo Nascimento

Fonte: blog.pluralsight.com

Seja um Mestre em Cisco IOS

Acesse o curso de “CCNA CCENT Online” em nossa área Premium.

DLTEC ACESSO PREMIUM

Aprenda desde os primeiros passos como configurar roteadores e switches Cisco para passar na sua primeira certificação e também ir bem no mercado de trabalho.

Clique aqui para ativar o curso e inciar seus estudos em nossa área de membros premium!

Não é membro premium? Clique aqui e saiba mais sobre a DlteC Premium.

Sobre Marcelo B do Nascimento

Cofundador da DlteC do Brasil e 7Bit Tecnologia, graduado em Engenharia Eletrônica/Telecomunicações pela UTFPR e pós-graduado em Redes e Sistemas Distribuídos pela PUC-PR. Trabalha na área de Tecnologia da Informação e Telecomunicações desde 1996. Certificado ITIL Foundations, CCNA Routing & Switching, CCNA Voice, CCNA Security e CCNP Routing & Switching.

  • Erick Alex

    Meu amigo me tira uma duvida, ou me dê uma ajuda.

    Tenho dois ranges de IP Publico no mesmo Link com a mesma Operadora, um /30 e um /27, tenho um Roteador Cisco com duas Interfaces, uma irei conectar ao modem/asga da operadora com um IP do /30 e a outra irei configurar um IP do /27, porém preciso que todos os outros IPs do /27 não utilizados estejam disponíveis.

    Pode me ajudar com esta configuração?

    • http://www.dltec.com.br DlteC do Brasil

      Oi Erick, infelizmente não dá porque o primeiro e último endereço não podem ser utilizados, o primeiro é a sub-rede e o último é o broadcast dessa sub-rede. Utilizáveis são somente do segundo ao penúltimo.

      Se fosse IPv6 já não teria esse problema, além de ter muito mais endereços disponíveis você também pode usar todos eles para endereçar seus hosts! Mas isso é outra história…

      Prof Marcelo Nascimento
      DlteC do Brasil

      • Erick Alex

        Boa tarde, é realmente isso que Eu preciso, utilizar todos os IP Públicos do validos do /27.

        Como Eu faria esta configuração no IOS?

        • http://www.dltec.com.br DlteC do Brasil

          É só fazer o normal, configura um dos IPs válidos na interface do roteador e o resto dos IPs válidos coloca no seu DHCP ou então configura estático nas placas de redes dos computadores ou servidores.

          Prof Marcelo Nascimento
          DlteC do Brasil

  • Dioclides Perna Wanderley

    Prof Marcelo, tenho pouco conhecimento em redes de computadores, preciso de que tenha um começo do curso realmente das primeiras lições, pois só assim consigo acompanhar.

  • Dioclides Perna Wanderley

    Prof Marcelo, tenho pouco conhecimento em redes de computadores, preciso de que tenha um começo do curso realmente das primeiras lições, pois só assim consigo acompanhar.