Algumas dicas para utilizar melhor a busca de informações no show running-config com Cisco IOS

Tempo de leitura: 1 minuto

Olá meus amigos e alunos, no dia a dia o show running-config acaba tendo que ser muito consultado para verificarmos se as configurações que estamos fazendo estão realmente corretas ou então procurar informações para apagar ou acrescentar parâmetros.

Duas dicas interessantes que eu utilizo muito em meus estudos são a utilização do “section” e verificar também a configuração de uma interface isolada. Vamos começar verificando a configuração da interface fast 0/0.

DlteC-FW-GW#show running-config interface fast0/0
Building configuration…

Current configuration : 231 bytes
!
interface FastEthernet0/0
description $FW_INSIDE$
ip address 192.168.10.2 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled
end

DlteC-FW-GW#

Assim podemos rapidamente verificar todas as opções configuradas em uma interface específica. Agora vimos que o NAT está aplicado nessa interface e queremos ver só a configuração do NAT, podemos utilizar o section nesse caso, veja a seguir.

DlteC-FW-GW#show running-config | section ip nat
ip nat outside
ip nat inside
ip nat inside
ip nat inside
ip nat inside source list 1 interface FastEthernet0/0 overload
DlteC-FW-GW#

Com a opção “section ip nat” obtivemos as seções de configuração que iniciam com “ip nat”, inclusive a definição do NAT. Veja outro exemplo do uso do section abaixo, onde vamos verificar as configurações das lines VTY.

DlteC-FW-GW#show running-config | section line vty
line vty 0 4
exec-timeout 30 0
logging synchronous
transport input ssh
line vty 5 15
exec-timeout 30 0
logging synchronous
transport input ssh
DlteC-FW-GW#

Com esses comandos fica muito mais fácil que usar o “show run” e ficar procurando o que precisamos linha a linha!  😉

É isso aí pessoal, até um próximo artigo!

Prof Marcelo Nascimento

Venha conhecer nossos Cursos preparatórios para certificações Cisco  e tenha muito mais recursos para trabalhar com o Cisco IOS.

Cursos online, baixo custo, material atualizado, simulados, tutoria especializada e muito mais. Venha aprender redes, Cisco e muito mais com a DlteC do Brasil.

Sobre Marcelo B do Nascimento

Cofundador da DlteC do Brasil e 7Bit Tecnologia, graduado em Engenharia Eletrônica/Telecomunicações pela UTFPR e pós-graduado em Redes e Sistemas Distribuídos pela PUC-PR. Trabalha na área de Tecnologia da Informação e Telecomunicações desde 1996. Certificado ITIL Foundations, CCNA Routing & Switching, CCNA Voice, CCNA Security e CCNP Routing & Switching.