CCNA Voice – Telefonia IP Básica e CME com Packet Tracer

Tempo de leitura: 5 minutos

Olá caros Leitores, Alunos e Internautas! Nesse artigo vamos passar alguns comandos sobre a configuração do voice over ip (VoIP) disponíveis no Packet Tracer 5.3. Esses comandos serão úteis para que está se preparando para o CCNA Voice (ICOMM versão 8.0).

Neste artigo vamos ver os seguites tópicos

  • Como configurar o Call Manager ExpressTM (CME) básico em um roteador 2811 com base no CCNA Voice,
  • Como utilizar os dispositivos de telefonia do packet tracer 5.3

Topologia de Rede

CCNA Voice – topologia

Vamos montar uma topologia bem básica com apenas dois telefones IP para ficar mais simples, porém você pode expandir e colocar quantos telefones e roteadores desejar.

Uma dica sobre os telefones IP é que eles não irão ligar sozinhos, pois os switches não tem PoE, portanto você vai ter que mover o cabo da fonte para o conector do telefone IP. Veja a figura 1 abaixo com a dica de ligação da energia do telefone IP. Veja a figura abaixo.

CCNA Voice – Telefone IP

Configurando a interface FastEthernet 0/0 e o DHCP no RouterA (2811)

Vamos iniciar as configurações, porém note que vamos mostrar o necessário para fazer a parte de telefonia funcionar e omitiremos comandos básicos do CCNA Voice.

RouterA>enable
RouterA#configure terminal
RouterA(config)#interface FastEthernet0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#no shutdown

O próprio roteador servirá nesse caso como servidor DHCP e para o CME é preciso que você forneça o IP do servidor TFTP para que os telefones possam buscar seu firmware e arquivos de configuração. Isso é feito com a opção 150 do DHCP. Veja a configuração abaixo:

RouterA(config)#ip dhcp pool VOICE
RouterA(dhcp-config)#network 192.168.10.0 255.255.255.0
RouterA(dhcp-config)#default-router 192.168.10.1
RouterA(dhcp-config)#option 150 ip 192.168.10.1

Configurando o Call Manager Express (telephony service no RouterA)

Agora vamos ativar o Call Manager Express (telephony service) no RouterA para habilitar o VoIP em nossa rede.

RouterA(config)#telephony-service
RouterA(config-telephony)#max-dn 5
RouterA(config-telephony)#max-ephones 5
RouterA(config-telephony)#ip source-address 192.168.10.1 port 2000
RouterA(config-telephony)#auto assign 1 to 5

Os comandos básicos e obrigatórios para configurar o CME estão dentro do modo de configuração do telephony-service. O Max-dn define o número máximo de linhas que você vai ter, já o max-ephones define o máximo de telefones físicos que você vai ter. Cada modelo de roteador permite um número máximo de telefones IP para o CME.

O comando “ip source-address 192.168.10.1 port 2000” define que o roteador 192.168.10.1 será o responsável pelo registro dos telefones através da porta 2000.

Por último temos o auto-assign, comando que faz o registro automático dos telefones e vincula os DNs (directory numbers ou linhas) aos telefones físicos, economizando comandos para criação dos telefones físicos (ephones). Na prática quase não utilizamos essa técnica e configuramos os telefones IP inserindo os ephones manualmente, vinculando o MAC de cada telefone a um ramal (DN).

Configurando a “voice vlan” no SwitchA

Como vamos utilizar apenas telefones não vamos ter duas VLANs separadas para voz e dados, por isso vamos utilizar a VLAN 1 mesmo como VLAN de Voz. Esse comando é utilizado para separar o tráfego de voz e dados, por isso se você for utilizar computadores nas portas de switch do telefone IP você precisará criar 2 VLANs, onde o tráfego de voz é passado pela voice vlan e o de dados pela vlan de acesso normal. Vamos configurar as portas de 1 a 5 para conectar telefones IP, veja abaixo:

SwitchA(config)#interface range fa0/1 – 5
SwitchA(config-if-range)#switchport mode access
SwitchA(config-if-range)#switchport voice vlan 1

Configurando o ramal do telefone (directory number do IP Phone 1)

O ramal (extensão/extension/linha) é chamado de número de diretório (directory number ou DN). Apesr dp ‘IP Phone 1’ estar conectado ao SwitchA e já estar com a VLAN de voz ele não vai subir sozinho, pois precisamos configurar os ramais que esses telefones irão utilizar para serem capazes de se comunicar entre si. Para isso precisamos ir no RouterA para definir os números de telefon ou DNs que iremos utilizar nos telefones IP. Isso é feito com o comando “ephone-dn 1” (nesse caso devido ao max-dn e max-ephone estarem em 5 podemos ter de 1 a 5), conforme abaixo:

RouterA(config)#ephone-dn 1
RouterA(config-ephone-dn)#number 54001

Portanto o primeiro telefone que conectarmos ao switch terá o ramal 54001 configurado nele. Faça o seguinte, ao montar a topologia lique apenas o telefone 1 e o 2 deixe desconectado, assim você garante que esse ramal estará no telefone 1. Depois que o telefone 1 estiver configurado você pode conectar o 2. Para verificar a configuração basta parar com o cursor do mouse encima do telefone. O registro (processo do telefone pegar as configurações e se registrar no roteador CME) pode demorar um pouco.

Verificando a configuração

Agora vamos verificar a config fo IP Phone A e ver se ele recebe o IP e o número 54001 do RouterA corretamente (lembre que pode demorar um pouco!).

CCNA Voice – config telefone

Clicando na aba GUI você tem uma visão gráfica do telefone e poderá fazer os testes, porém tudo é imaginário, ou seja, não vai tocar nada apenas aparecer mensagens do tipo “ringing”, etc.

ccna voice – telefone frontal

 

Configurando o DN para o IP Phone 2

Agora vamos inserir o ramal do IP Phone 2 e conectá-lo ao SwitchA . O telefone IP 2 terá o ramal 54002, veja os comandos abaixo.

RouterA(config)#ephone-dn 2
RouterA(config-ephone-dn)#number 54002

Verificando e testando a configuração

Agora basta abrir a aba GUI de cada telefone, clicar encima do monofone (handset) e discar o ramal do outro telefone. Para atender basta clicar sobre o monofone.

Vá até o telefone IP 2, disque 54001 e verifique se o IP phone 1 recebe a chamada.

Por enquanto é isso aí, em um próximo artigo vou mostrar como configurar os dial-peers.

Fonte: http://www.packettracernetwork.com/voipconfiguration.html

Quer aprender mais sobre como configurar e implementar telefonia IP em equipamentos Cisco?

Torne-se um assinante e faça os cursos CCNA Voice e Implementando Cisco CME.

Escolha seu plano de assinatura clicando aqui.

Sobre Marcelo B do Nascimento

Cofundador da DlteC do Brasil e 7Bit Tecnologia, graduado em Engenharia Eletrônica/Telecomunicações pela UTFPR e pós-graduado em Redes e Sistemas Distribuídos pela PUC-PR. Trabalha na área de Tecnologia da Informação e Telecomunicações desde 1996. Certificado ITIL Foundations, CCNA Routing & Switching, CCNA Voice, CCNA Security e CCNP Routing & Switching.

  • Daniel

    Olá, gostei, poderia me tirar uma dúvida, o CCNA Voice a prova é em português?

    • Olá Daniel, a prova do CCNA Voice que é a 640-461 ainda não está disponível em português, somente em inglês e japonês.

  • Muito bom. Acabei de passar no exame do CCNA Networking e preciso muito aprender o conteudo do CCNA Voice, não apenas para fazer a prova, mas sera exigido de mim no meu trabalho. Uma pergunta: O Exame do CCNA VOICE é bem genérico como o CCNA Networking, ou seja, cai muitas coisas sobre camada OSI, protocolos de roteamento, switching, etc. ou ele é totalmente voltado para a parte de telefonia IP?

    • Olá Fábio, fico feliz que você tenha gostado do artigo.

      Sobre a prova ela é voltada para a área de Telefonia IP e caem questões relacionadas a parte teórica de Telefonia IP e sobre os produtos da família de comunicações unificadas da Cisco (conceitos, configurações e troubleshooting).

      Veja o conteúdo do nosso curso CCNA Voice Online que você vai ter uma ideia do que pode ser cobrado na prova:
      – Introdução a Telefonia e Comunicações Unificadas Cisco
      1. Introdução
      2. Telefonia Tradicional versus Comunicações Unificadas
      3. O Ambiente de Comunicações Unificadas da Cisco
      4. Telefones IP Cisco e o Processo de Registro

      – CME – Call Manager Express
      5. CME – Cisco Call Manager Express – Introdução a Administração do Sistema
      6. CME – Gerenciando Dispositivos e Usuários
      7. CME – Configurando Placas de voz, Dial-Plan e QoS
      8. CME – Configurando Recursos Avançados de Voz

      – CUCM – Cisco Unified Communications Manager
      9. CUCM – Cisco Unified Communications Manager – Interfaces de Usuário e de Administrador
      10. CUCM – Gerenciando Dispositivos e Usuários
      11. CUCM – Introdução ao Plano de Discagem
      12. CUCM – Configurando Recursos de Telefonia
      13. CUCM – Configurando Recursos de Mobilidade

      – Unity e Presence
      14. Voice Mail – Integração com Unity Connection
      15. Habilitando o Presence

      – Gerenciamento e Troubleshooting
      16. Gerenciamento de Rede e Troubleshooting com CME
      17. Gerenciamento de Rede e Troubleshooting com CUCM
      18. Monitorando o Cisco Unity Connection

      Atenciosamente.

      Prof Marcelo Nascimento
      Coordenador e Tutor dos Cursos de Tecnologia da DlteC

  • Andriele Menegotto

    Olá, gostaria de saber como seria a configuração do QoS nesta topologia. Pesquisei e encontrei muito conteúdo, fiquei confusa em relação a isso. A idéia é dar prioridade para as chamadas, verifiquei em tutoriais que na maioria das vezes é configurado o bandwidht como política do QoS, isso automaticamente dá prioridade para as chamadas ? Não preciso necessariamente configurar a largura de banda em uma política Qos, certo ?Outra questão seria de como eu veria isso “funcionando”, por exemplo se eu acrescentar algumas máquinas com acesso à web e definisse uma prioridade para o VoIP, como eu veria isto em funcionamento ?

    Agradeço desde já.

    =)

  • Andriele Menegotto

    Olá, gostaria de saber como seria a configuração do QoS nesta topologia. Pesquisei e encontrei muito conteúdo, fiquei confusa em relação a isso. A idéia é dar prioridade para as chamadas, verifiquei em tutoriais que na maioria das vezes é configurado o bandwidht como política do QoS, isso automaticamente dá prioridade para as chamadas ? Não preciso necessariamente configurar a largura de banda em uma política Qos, certo ?Outra questão seria de como eu veria isso “funcionando”, por exemplo se eu acrescentar algumas máquinas com acesso à web e definisse uma prioridade para o VoIP, como eu veria isto em funcionamento ?

    Agradeço desde já.

    =)

    • Olá Andriele, primeiro agradecemos seu comentário. O QoS em não é somente “banda”, temos a marcação dos quadros, enfileiramento e priorização, na priorização podemos também fazer uma reserva de banda, por isso a configuração é às vezes difícil de entender. Com a marcação dos quadros os switches e roteadores entendem que determinado tráfego deve ser passado na frente de outros, porém nem sempre isso é suficiente, por isso se faz também uma reserva de bando, porque certos protocolos tendem a ocupar quanta banda tiver disponível em suas comunicações. Tudo isso é feito na telefonia IP para garantir a banda correta e minimizar o atraso (delay) da rede, os dois fatores mais importantes para a qualidade da voz sobre IP.

      No CCNA Voice é estuda o básico sobre QoS e recomendado o uso do Auto-qos, recurso dos switches e roteadores da Cisco para ativação de um template de QoS com base na função da porta.

  • Van Peter Peter

    Tutorial super manero! eu gostaria de saber como fazer a mesma coisa, mas usando um switch PoE para permitir que o PC conecte-se a rede atravez do phone mas usando uma vlan de dados, se assim for, estaremos usando o recurso de entrocamento, para que um único cabo transporte 2 vlans para cada estação que necessitar de acessar voz e dados ao mesmo tempo.

  • Van Peter Peter

    Tutorial super manero! eu gostaria de saber como fazer a mesma coisa, mas usando um switch PoE para permitir que o PC conecte-se a rede atravez do phone mas usando uma vlan de dados, se assim for, estaremos usando o recurso de entrocamento, para que um único cabo transporte 2 vlans para cada estação que necessitar de acessar voz e dados ao mesmo tempo.

    • É só definir a VLAN de dados com o bom e velho “switchport access vlan 10”, se a vlan de dados for a 10 como exemplo na mesma porta.

      Prof Marcelo Nascimento
      DlteC do Brasil

  • Rubens Simao Carlos

    Boa noite, gostei muito da apresentação. Só gostaria que tirasse uma pequena duvida. Como faço para cria PIN para usuario do telefone via comando no call manager ??? Fico no aguardo email para contato: rubens.ccna@hotmail.com

  • Wesley Silvério

    Prezado professor Marcelo, porque que no Router 2811, quando eu dou o comando Router# telephony-service ele volta uma mensagem de comando invalido? Obrigado e um grande abraço

  • Wesley Silvério

    Prezado professor Marcelo, porque que no Router 2811, quando eu dou o comando Router# telephony-service ele volta uma mensagem de comando invalido? Obrigado e um grande abraço

    • Oi Wesley, esse comando é em modo de configuração global e não em modo privilegiado, você esqueceu do “config term”.

      Prof Marcelo Nascimento
      DlteC do Brasil

  • Diogo

    Boa noite, estou tentando configurar uma VLAN de voz no switch 2960 no PT sem sucesso. Coloco os comandos acima, mas quando dou um show VLAN, minha VLAN de voz aparece sem nenhuma interface configurada. Este switch no Packet Tracer suporta Vlan de voz?
    Obrigado,

    • Oi Diogo, suporta sim, quando ele não suporta um comando ele nem entra, dá erro de cara…

      Prof Marcelo Nascimento
      DlteC do Brasil

  • joao carlos

    A prova ccna voice sera valida até quando,