Configurando Roteamento entre VLAN em um Switch Layer 3 Cisco

Tempo de leitura: 6 minutos

Nesse artigo vamos tratar da configuração do Roteamento entre VLAN em um Switch Layer 3 Cisco.

O roteamento entre VLAN faz parte do material atual das provas de certificação CCNA R&S (CCENT, ICND-2 e CCNAX), CCNP SWITCH e também muitas vezes vamos nos deparar com esse tipo de configuração na prática.

Utilizamos para fazer o exemplo de roteamento entre VLAN um  switch layer 3 Cisco modelo Catalyst 3550, porém a configuração pode ser feita em outros modelos de switch layer 3 Cisco, como por exemplo o Catalyst 3560, 3750, Catalyst 4500/4000 com Sup II+ ou Catalyst 6500/6000.

Configurando Roteamento entre VLAN

Abaixo segue a topologia proposta para as configurações do roteamento entre VLAN.

Roteamento entre VLAN em Switch L3
Vamos ver agora as configurações passo a passo para configurar o roteamento entre VLAN em Switch L3 Cisco seguindo a topologia acima.

1. Habilite o roteamento IP no switch layer 3 Cisco:

Switch(config)#ip routing

Se o switch layer 3 Cisco não aceitar esse comando verifique se o IOS instalado nele comporta layer 3, se não faça um upgrade para uma imagem de IOS SMI Software Release12.1(11)EA1 ou superior, ou então uma imagem de IOS EMI e repita o passo acima. Lembre que nem todos os switches suportam roteamento!

Algumas outras configurações extras e verificando se o comando foi aceito com “show run”:
hostname Switch
!
!
ip subnet-zero –> para aceitar todas as subredes
ip routing –> comando que ativou o protocolo IP
!
vtp mode transparent  –> vamos configurar o switch como transparente e não utilizar o VTP

2. Crie as VLANs que serão roteadas pelo switch layer 3 Cisco no modo de configuração global:
Switch#config term
Switch(config)#vlan 2
Switch(config-vlan)#Name VLAN2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#Name VLAN3
Switch(config-vlan)#vlan 10
Switch(config-vlan)#Name VLAN10
Switch(config-vlan)#end
Switch#

3. Elabore o projeto da alocação de IPs para cada VLAN que você deseja utilizar, escolhendo a subrede, máscara e qual IP você vai endereçar cada VLAN. Lembre-se que o IP da VLAN será o gateway dos PCs.

4. Configure as interfaces VLAN conforme projeto feito no passo anterior. Essas interfaces são chamadas de SVIs ou Switched Virtual Interfaces.

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface Vlan2
Switch(config-if)#ip address 10.1.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config)#interface Vlan3
Switch(config-if)#ip address 10.1.3.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config)#interface Vlan10
Switch(config-if)#ip address 10.1.10.1 255.255.255.0
Switch(config-if)#no shutdown

5. Configurando a interface do switch layer 3 Cisco que entronca com o roteador. Esse tipo de interface é chamada de Routed Interface ou Routed Port, ou seja, uma porta roteada que recebe endereço IP e funciona de forma similar a uma interface de um roteador.

Switch(config)#interface FastEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 200.1.1.1 255.255.255.0
Switch(config-if)#no shutdown

O comando “no switchport” faz com que a interface tenha recursos de camada 3 (Layer 3), lembrando que o IP deve estar na mesma subrede que o roteador.

Você também poderia configurar um trunk entre o roteador e o switch e fazer o roteamento entre VLAN sem problema algum, apenas utilizamos um comando adicional para ilustrar outra possibilidade de conexão para os switches e ampliar seus conhecimentos.

6. Configure o gateway padrão para o switch com uma rota estática apontando para o roteador, conforme a topologia desse exemplo.

Switch(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2

Você lembra do comando “ip default-gateway” que que configura o gatewaya em switches L2?

Agora como o roteamento está habilitado (comando “ip routing“) ele não é mais necessário e sim temos que configurar o switch como se fosse um roteador utilizando uma rota estática padrão para definir o gateway.

Agora seu switch encaminha pacotes e não é mais um host da rede, passou a ser um “roteador” capaz dele mesmo fazer o roteamento entre VLAN.

7. Agora você pode configurar os computadores em cada VLAN conforme sugestão da topologia e fazer os testes de ping e telnet para verificar se a configuração foi bem sucedida.

Lembre que o gateway padrão dos computadores será o IP configurado na “interface VLAN” (SVI) do switch e não mais o do roteador, agora quem vai rotear os pacotes entre as VLANs vai ser o switch L3!

Para verificar a configuração nada muda, começamos com o show ip route para ver as entradas de roteamento do switch layer 3 Cisco:

Switch#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2,
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2,
ia – IS-IS inter area, * – candidate default, U – per-user static route,
o – ODR, P – periodic downloaded static route

Gateway of last resort is 200.1.1.2 to network 0.0.0.0

     200.1.1.0/30 is subnetted, 1 subnets
C       200.1.1.0 is directly connected, FastEthernet0/48
10.0.0.0/24 is subnetted, 3 subnets
C       10.1.10.0 is directly connected, Vlan10
C       10.1.3.0 is directly connected, Vlan3
C       10.1.2.0 is directly connected, Vlan2
S*   0.0.0.0/0 [1/0] via 200.1.1.2

Note na saída da tabela de roteamento acima que agora o switch layer 3 cisco sabe as redes que configuramos para cada VLAN (dentro das interfaces VLAN) e tem como fazer o roteamento entre VLAN sem a necessidade de outro dispositivo.

No caso de um dos hosts tentar acessar outras redes dentro da rede corporativa ou IPs da Internet o pacote será encaminhado para o IP configurado na interface VLAN (que é o roteador padrão que deve ser configurado nos hosts) e o switch layer 3 cisco fará  encaminhamento desse pacote ao roteador padrão, conforme configurado na rota padrão identificada com o “S*”.

Além disso, você poderia utilizar o comando “show ip interface brief” para listar de maneira resumida a lista das interfaces IP e seus status no switch.

Esse comando vai confirmar se seu switch é capaz de fazer o roteamento entre VLAN.

Agora é praticar e fazer mais testes!

Espero que você tenha gostado desse artigo sobre roteamento entre VLAN e deixe uma mensagem nos comentários aqui mesmo nesse artigo, logo ali abaixo!

Ah, se tiver dúvidas sobre roteamento entre VLAN pode perguntar também que vamos  ajudar…

Prof Marcelo Nascimento

Fonte: cisco.com

Aprenda Roteamento entre VLAN e as Tecnologias mais Quentes do Mercado! 

O estudo do roteamento entre VLAN e Switching na DlteC começa pelo curso CCNA CCENT.

Você pode acessar o nosso curso online assinando nosso plano anual.

Saiba como tornar-se assinante e ter acesso ao CCENT e TODOS os demais Cursos Online da DlteC clicando aqui: Plano de Assinatura DlteC

Sobre Marcelo B do Nascimento

Cofundador da DlteC do Brasil e 7Bit Tecnologia, graduado em Engenharia Eletrônica/Telecomunicações pela UTFPR e pós-graduado em Redes e Sistemas Distribuídos pela PUC-PR. Trabalha na área de Tecnologia da Informação e Telecomunicações desde 1996. Certificado ITIL Foundations, CCNA Routing & Switching, CCNA Voice, CCNA Security e CCNP Routing & Switching.

  • http://www.facebook.com/rafaelcantarela Rafael Cantarela

    Gostaria de tirar uma dúvida, suponha que tenho um cenário que tenho as seguintes VLANs:

    1 – Nativa2 – Servidores4 – VLAN45 – VLAN56 – VLAN6

    Como criaria rotas pra indicar que as subnets da VLAN4, 5 e 6 se comunicam com a VLAN de servidores apenas, mas n se comunicam entre si?Obrigado?

    • http://www.dltec.com.br DlteC do Brasil

      Olá Rafael, nesse cenário que você apresentou no roteamento não fica legal fazermos essa restrição e sim com uma access-list (ACL).

      O roteamento fica normal, todo mundo pode alcançar um ao outro e depois você insere uma lista de acesso fazendo as restrições necessárias, como se fosse um “firewall”.

      Esperamos ter ajudado.

  • http://www.facebook.com/luis.candido.104 Luis Cunha

    MUITO SHOW CARA!! OBRIGADO!

  • http://www.facebook.com/luis.candido.104 Luis Cunha

    MUITO SHOW CARA!! OBRIGADO!

    • http://www.facebook.com/bscimento Marcelo Brenzink Do Nascimento

      Obrigado Luis!

  • Paulo Moreira

    Muito bom, conhece a ferramenta GNS 3? saberia me dizer como faço para configurar no GNS 3 vlans numa rede aonde tem 2 computadores ligado a um switch, do switch vai para o router, mas a maquina nao chega a pingar no router. se ligo direto no router vai caso contrario nao pinga.

  • Paulo Moreira

    Muito bom, conhece a ferramenta GNS 3? saberia me dizer como faço para configurar no GNS 3 vlans numa rede aonde tem 2 computadores ligado a um switch, do switch vai para o router, mas a maquina nao chega a pingar no router. se ligo direto no router vai caso contrario nao pinga.

    • http://www.dltec.com.br DlteC do Brasil

      Oi Paulo, provavelmente você está com problemas na configuração do roteamento entre VLANs.
      Prof Marcelo Nascimento
      DlteC do Brasil

  • Hélder Portela

    Boas, é possível, ao invés de utilizar um switch L3, utilizar um L2 e um router e conseguir que todas as VLAN’s não se conectem mas todas conectarem-se ao servidor e à Internet ?

    • http://www.dltec.com.br DlteC do Brasil

      Sim, se for com roteador Cisco podemos utilizar sub-interfaces para fazer o roteamento entre VLANs e utilizar listas de controle de acesso (ACL) para fazer bloqueios e permissões entre as sub-redes. O mesmo pode ser feito com switch L3.

      Prof Marcelo Nascimento

      • Hélder Portela

        Então terei de criar as VLAN’s normalmente no switch e utilizar as ACL’s no router ?

        • http://www.dltec.com.br DlteC do Brasil

          Pelo pouco que você você escreveu criando as VLANs no switch, fazendo o roteamento entre VLAN e as ACLs no roteador deve resolver, mas como não conheço a complexidade da sua rede sugiro que antes de aplicar qualquer coisa em ambiente de produção (se você não tem experiência) contrate um empresa ou um consultor para te auxiliar.

          Prof Marcelo Nascimento

          • Hélder Portela

            Sim … Muito obrigado pela sua ajuda …

            Cumprimentos

  • Jefferlhe Jr.

    Boa tarde,

    Estou tentando configurar as interfaces vlans, mais somente uma delas fica em up, o restante fica tudo down, mesmo dando o comando no shutdown não sobe, teria alguma outra coisa que poderia ser verificado?

    Obrigado.

    • http://www.dltec.com.br DlteC do Brasil

      Oi Jefferlhe, pelo que você descreve seu switch não é L3 e sim L2, que modelo de switch você está usando?

      Prof Marcelo Nascimento
      DlteC do Brasil