Melhorando a pesquisa em comandos show – Curso Cisco CCNA

Tempo de leitura: 3 minutos

Você já teve dificuldade em encontrar algo específico quando utiliza comandos show via CLI no Cisco IOS?

Este artigo vem de encontro à necessidade passada por alguns alunos durante as aulas do Curso Cisco CCNA sobre pesquisa de parâmetros durante a configuração de roteadores e switches.

Existem maneiras simples de facilitar a busca de informações e agilizar o processo de troubleshooting durante as aulas práticas utilizando comandos adicionais para filtrar informações, por exemplo, veja abaixo algumas situações com o comando Show Running-Config.

Vamos utilizar primeiro os “output modifiers” que podem ser inseridos utilizando o símbolo “|”, conforme abaixo:

Router#show running-config | ?
 append    Append redirected output to URL (URLs supporting append operation
 only)
 begin     Begin with the line that matches
 exclude   Exclude lines that match
 include   Include lines that match
 redirect  Redirect output to URL
 section   Filter a section of output
 tee       Copy output to URL
 

Vamos utilizar três deles abaixo, o include, exclude e begin. No primeiro exemplo temos o comando utilizando o include, o qual traz as linhas que possuem a palavra “line”. O line foi escolhido aleatoriamente e poderia ser “interface”, por exemplo, trazendo as linhas que contém a palavra interface.

Router#show running-config | include line
line con 0
line aux 0
line vty 0 4

No segundo exemplo utilizamos o “begin”, que traz a configuração a partir da linha que conter a palavra “line”. Esse exemplo é interessante, pois para ver a configuração das lines você precisa ir até o final do arquivo de configuração, assim elas já vem sem você precisar ficar apertando o “enter” ou a “barra de espaço”.

Router#show running-config | begin line
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

 

Nesse terceiro exemplo fizemos uma pesquisa excluindo o que contiver a palavra “line” com o parâmetro “exclude”. Note que veio a configuração completa do roteador menos as configurações das linhas de console, VTY e auxiliar.

Router#show running-config | exclude line
Building configuration...

Current configuration : 746 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Serial0/1/0
 no ip address
 shutdown
!
ip http server
no ip http secure-server
!
control-plane
!
 login
!
scheduler allocate 20000 1000
end

Por último, vamos mostrar um comando bem simples para quando você deseja visualizar a configuração de uma interface específica. O mesmo princípio pode ser utilizado no “show interfaces”.

Router#
Router#show running-config interface fastEthernet 0/0
Building configuration...

Current configuration : 83 bytes
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
end

Router#

Até um próximo artigo e desejamos bons estudos e uma boa prova!

DLTEC ACESSO PREMIUM

Acesse o curso de “CCNA CCENT e CCNA ICND-2 Online” em nossa área Premium.

Prepare-se para o CCNA e aprenda várias tecnologias fundamentais para área de Redes como STP, RSTP, OSPF, OSPFv3, troubleshooting e muito mais.

Clique aqui para ativar o curso e inciar seus estudos em nossa área de membros premium!

Não é membro premium? Clique aqui e saiba mais sobre a DlteC Premium.

Sobre Marcelo B do Nascimento

Cofundador da DlteC do Brasil e 7Bit Tecnologia, graduado em Engenharia Eletrônica/Telecomunicações pela UTFPR e pós-graduado em Redes e Sistemas Distribuídos pela PUC-PR. Trabalha na área de Tecnologia da Informação e Telecomunicações desde 1996. Certificado ITIL Foundations, CCNA Routing & Switching, CCNA Voice, CCNA Security e CCNP Routing & Switching.