Saída para Internet com Rota Estática e IGP em Roteadores e Switches L3 Cisco

Tempo de leitura: 12 minutos

Você sabe como configurar de forma rápida e eficaz a saída para Internet utilizando rota estática em Roteadores e Switches L3 Cisco?

Essa configuração pode ser realizada algumas maneiras diferentes, porém vou manter aqui o foco no pessoal nível CCENT, ICND-2 e CCNA R&S colocando uma “pimentinha”…

Nesse artigo você vai aprender os seguintes tópicos:

Vou focar em uma rede com uma saída única para a Internet através de rota estática, posteriormente vou publicar outro artigo com uma opção prática e rápida para redes com múltiplos links de Internet.

Na realidade se você já tem uma rede com mais de uma saída de Internet no mesmo roteador você pode ver como fazer uma opção de configuração através de rota estática flutuante clicando aqui.

Mas chega de blábláblá e vamos começar… Pegue seu bloco de notas e mãos a obra!

Saída para a Internet

A saída para a Internet em roteadores e switches L3 (layer 3 ou camada 3) Cisco utiliza o mesmo conceito que quaisquer outros fabricantes utilizam, sendo realizada normalmente via uma rota estática padrão.

Essa rota estática padrão é também chamada de rota estática padrão, gateway padrão ou default gateway.

O gateway padrão nada mais é que um roteador ou switch L3 posicionado na borda da rede corporativa fazendo a interconexão entre a Intranet (sua rede corporativa) com a Internet.

Saída para Internet

Como estamos focando em redes corporativas e não de provedores de Serviço (ISPs – Internet Service Providers) a topologia mais utilizada é ter um protocolo de roteamento interno (IGP – Interior Gateway Protocol) rodando dentro da Intranet e a conexão com a Internet feita via rota estática padrão.

Portanto, nos roteadores internos teremos nas tabelas de roteamento as redes privadas RFC 1918 utilizadas na rede mais uma rota estática padrão (marcada com um asterisco) indicando a saída para a Internet ou para redes que esses roteadores não conheçam.

Se você não utilizar um protocolo de roteamento dinâmico IGP como RIPv2, OSPF ou EIGRP será necessário criar a rota estática padrão em cada um dos roteadores da rede interna.

Com os protocolos de roteamento dinâmico essa tarefa é mais simples, pois você pode utilizar os recursos desses protocolos e através do gateway anunciar automaticamente essa rota estática para a Internet sem precisar fazer nada nos demais roteadores da Intranet.

O maior cuidado ao criar uma rota estática padrão é de não causar loops de roteamento (loops de camada-3), tenha muito cuidado com isso.

A seguir você vai aprender a  criar a rota estática padrão sem criar um loop de roteamento…

Saída para Internet Via Rota Estática

De uma forma resumida podemos dizer que a rota estática padrão ou Gateway of last resort nos roteadores tem a função de ser o destino para qual o roteador ou switch L3 enviará pacotes quando não houver uma entrada na tabela de roteamento para aquela rede de destino.

Quando um roteador recebe um pacote para encaminhar ele analisa a rede de destino e busca em sua tabela de roteamento uma rota correspondente.

Sem uma rota estática padrão o roteador irá buscar a rota explícita (específica) para determinado endereço em sua tabela de roteamento e caso não seja encontrada, o pacote será descartado.

Por esse motivo a rota estática padrão é intitulada muitas vezes como a “saída para internet” ou saída padrão, pois quando não há rota específica para a rede de destino o pacote é encaminhado para ela.

Nos roteadores e switches L3 ela deve ser configurada com uma rota estática para a rede 0.0.0.0 com máscara 0.0.0.0, ou seja, todos os endereços IP’s menos os que ele conhece na tabela de roteamento.

Para a configuração de um gateway default você pode utilizar o comando: “ip route 0.0.0.0 0.0.0.0 interface/gateway”.

A seguir vamos estudar um exemplo prático onde o gateway default é o endereço IP 192.168.1.1.

RA#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RA(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
RA(config)#end
RA#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 a - application route
 + - replicated route, % - next hop override
Gateway of last resort is 192.168.1.1 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 192.168.1.1
 192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet0/0
L 192.168.1.225/32 is directly connected, GigabitEthernet0/0
RA#

Note que na tabela de roteamento você reconhecerá a rota estática padrão com um asterisco (*) ao lado do “S” que indica que ela é uma rota estática, além de aparecer o endereço IP no campo “Gateway of last resort is…”.

O endereço IP que você deve utilizar nesse comando é sempre de um vizinho diretamente conectado ao seu roteador, ou seja, o endereço da interface do ISP que seu gateway está conectado.

Se você for utilizar a interface como opção aí insira a interface local do seu gateway que está conectada ao roteador do ISP.

Para os roteadores internos você deve apontar a saída para Internet na direção do gateway e é aí que vem o risco de loops de camada 3.

Se você configurar uma rota estática de um roteador apontando para o vizinho e esse vizinho apontar para seu roteador é quando criamos o loop de roteamento, pois quando um não conhecer uma rede de destino vai enviar para o outro até o TTL chegar a zero.

Veja a figura abaixo para entender o loop de roteamento.

Rota Estática Padrão - Loop de Roteamento

Utilizando a figura acima, suponha que sua Internet está conectada a R1 e todos os links tem a mesma velocidade, portanto você deveria criar rota de R3 apontando para R1, de R4 também apontando para R1 e de R2 indo para R3 ou para R4 e aí saindo para R1, uma vez que R2 não tem link direto para R1.

A seguir vamos estudar como fazer a divulgação dessa rota estática padrão através dos protocolos de roteamento dinâmico RIP, OSPF e EIGRP.

Com um protocolo dinâmico fica bem mais simples a configuração, pois é só fazer tudo em um roteador só que os outros receberão a rota estática padrão via anúncio, tudo isso sem necessidade de teclar um único comando nos demais roteadores internos.

Anunciando a Saída para Internet no RIP e OSPF

Para facilitar a divulgação da rota padrão os protocolos RIP e OSPF possuem um comando em modo de configuração de roteador que deve ser inserido no roteador que possui o link de saída para Internet.

Dessa forma a saída padrão é anunciada automaticamente para todos os demais roteadores.

O comando é o “default-information originate” que deve ser aplicado dentro do modo de configuração do RIP ou OSPF.

Resumindo, no roteador com a saída para Internet basta configurar uma rota estática padrão e digitar o comando “default-information originate” dentro da configuração do RIP ou OSPF que o próprio protocolo de roteamento dinâmico fará o anúncio dessa rede para os demais routers, veja um exemplo abaixo.

hostname Router-A
!
ip route 0.0.0.0 0.0.0.0 200.200.200.2
!
router ospf 1
 log-adjacency-changes
 network 10.0.4.0 0.0.0.255 area 0
 network 192.168.1.8 0.0.0.3 area 0
 network 192.168.1.4 0.0.0.3 area 0
 default-information originate

No roteador vizinho a rota padrão distribuída pelo comando “default-information originate” é marcada como uma rota externa do tipo 2 pelo OSPF (O*E2 0.0.0.0/0) e com um asterisco indicando que a rota é candidata a default, veja na saída do comando abaixo.

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
 i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
 * - candidate default, U - per-user static route, o - ODR
 P - periodic downloaded static route
Gateway of last resort is 192.168.1.9 to network 0.0.0.0
10.0.0.0/24 is subnetted, 5 subnets
O 10.0.0.0 [110/101] via 192.168.1.6, 00:05:41, Serial0/0/0
O 10.0.1.0 [110/101] via 192.168.1.6, 00:05:41, Serial0/0/0
C 10.0.2.0 is directly connected, FastEthernet0/0
C 10.0.3.0 is directly connected, FastEthernet0/1
O 10.0.4.0 [110/101] via 192.168.1.9, 00:05:41, Serial0/0/1
 192.168.0.0/32 is subnetted, 1 subnets
C 192.168.0.2 is directly connected, Loopback0
 192.168.1.0/30 is subnetted, 3 subnets
O 192.168.1.0 [110/1662] via 192.168.1.6, 00:05:41, Serial0/0/0
C 192.168.1.4 is directly connected, Serial0/0/0
C 192.168.1.8 is directly connected, Serial0/0/1
O*E2 0.0.0.0/0 [110/1] via 192.168.1.9, 00:05:41, Serial0/0/1
RouterB#

O RIP não marca a rota como externa, apenas insere o asterisco indicando que a rota é uma candidata a default.

A seguir vamos ver como anunciar automaticamente a rota padrão através de redistribuição.

Anunciando a Saída para Internet via Redistribuição no EIGRP

Em redes que rodam o protocolo EIGRP podemos criar uma rota estática padrão e redistribuí-la dentro do processo de roteamento do EIGRP com o comando “redistribute static”.

Veja exemplo abaixo.

ip route 0.0.0.0 0.0.0.0 200.200.200.2
!
router eigrp 100
 redistribute static 
 passive-interface FastEthernet0/0
 passive-interface FastEthernet0/1
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary

Nos vizinhos que recebem essa rota nos anúncios do EIGRP a rota é marcada como externa e recebe uma métrica igual a 170 (D*EX 0.0.0.0/0 [170/3097600]) e com um asterisco indicando que ela é candidata a default, veja um exemplo do comando abaixo.

RouterB#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
 i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
 * - candidate default, U - per-user static route, o - ODR
 P - periodic downloaded static route
Gateway of last resort is 192.168.1.9 to network 0.0.0.0
10.0.0.0/24 is subnetted, 5 subnets
 D 10.0.0.0 [90/3074560] via 192.168.1.6, 00:13:55, Serial0/0/0
 D 10.0.1.0 [90/3074560] via 192.168.1.6, 00:13:55, Serial0/0/0
 C 10.0.2.0 is directly connected, FastEthernet0/0
 C 10.0.3.0 is directly connected, FastEthernet0/1
 D 10.0.4.0 [90/3074560] via 192.168.1.9, 00:13:55, Serial0/0/1
 192.168.0.0/32 is subnetted, 1 subnets
 C 192.168.0.2 is directly connected, Loopback0
 192.168.1.0/30 is subnetted, 3 subnets
 D 192.168.1.0 [90/41024000] via 192.168.1.9, 00:13:55, Serial0/0/1
 [90/41024000] via 192.168.1.6, 00:13:55, Serial0/0/0
 C 192.168.1.4 is directly connected, Serial0/0/0
 C 192.168.1.8 is directly connected, Serial0/0/1
 D*EX 0.0.0.0/0 [170/3097600] via 192.168.1.9, 00:13:55, Serial0/0/1
 RouterB#

O interessante é que essa opção de configuração de rota e redistribuição pode ser utilizada também no RIP e OSPF, porém como eles já tem um comando específico para esse fim a redistribuição acaba não sendo muito utilizada para anunciar rotas padrões para esses dois protocolos.

Dicas e Conclusão

Agora você pode montar uma topologia utilizando o GNS3 ou Packet Tracer e aplicar os conhecimentos que aprendeu nesse artigo.

É muito importante a implementação, pois lendo o artigo pode parecer fácil, mas é só no campo de batalha que vamos realmente desenvolver nossas habilidades e fixar os conhecimentos! Por isso pratique muito!

Apesar de não ter citado antes, saiba que as mesmas configurações estudadas para roteadores podem ser utilizadas em switches L3 que suportam roteamento IP.

Uma dica, antes de configurar a parte de roteamento ative essa função com o comando “ip routing” em modo de configuração global no seu switch L3.

No Packet Tracer tem uma opção de switch 3650 Multilayer que você pode utilizar nos testes.

No GNS3 para testar switching é aconselhável utilizar o IOU (Cisco IOS on UNIX).

Se você não tem muita intimidade com o Packet Tracer ou GNS3 ensinamos tudo isso e como utilizá-los no curso de Simuladores de Redes.

Se você gostou do assunto e está procurando desenvolver suas habilidades em roteamento vou indicar alguns outros artigos do nosso blog que escrevi a um tempo atrás e poderão te ajudar, veja a lista abaixo:

  1. Balanceamento de carga em protocolos de roteamento
  2. Configurando o balanceamento de carga no RIP, OSPF e EIGRP

Espero que o artigo sobre rota estática para a Internet tenha sido realmente de grande valia para você e aguardo seus comentários, dúvidas e sugestões no final dessa página na área de comentários!

É só descer um pouco que você encontra a área de comentários está lá embaixo…

Claro que você também pode usar os botões de compartilhamento se achar que o artigo vai ser útil para seus amigos.

Que a força esteja com você e até uma próxima!

ACL lightsabers-small

Prof Marcelo Nascimento

DLTEC ACESSO PREMIUM

Acesse os cursos “CCNA CCENT, CCNA ICND-2 e CCNP ROUTE Online” em nossa área Premium.

Aprenda a teoria e a prática de roteamento (Rota Estática, RIPv2, EIGRP, OSPF e BGP) em roteadores e switches Cisco que utilizam o sistema operacional Cisco IOS.

Clique aqui para ativar o curso e inciar seus estudos em nossa área de membros premium!

Não é membro premium? Clique aqui e saiba mais sobre a DlteC Premium.

Sobre Marcelo Brenzink do Nascimento

Sou Cofundador da DlteC do Brasil, graduado em Engenharia Eletrônica/Telecomunicações pela UTFPR e pós-graduado em Redes e Sistemas Distribuídos pela PUC-PR. Trabalho na área de Tecnologia da Informação e Telecomunicações desde 1996. Certificado ITIL Foundations, CCNA Routing & Switching, CCNA Voice, CCNA Security e CCNP Routing & Switching.

  • Diego Teruel

    Muito Bom seu artigo Prof Marcelo. Como realizar esta configuração com rota estática, quando temos um roteador de borda destes fornecidos pelas operadoras de telefonia do tipo ADSL e utilizamos vlan’s? Tenho está dúvida, pois, tentei configurar em um laboratório, criei a rota estática com três vlans, porém a internet só funcionava na sub rede da vlan que estava o roteador.

    • Oi Diego, funciona sim, mas se apenas uma sub-rede está acessando a Internet é porque você tem algum problema de roteamento dentro da sua Intranet.

      Se ninguém saísse para a Internet seria com a rota padrão, mas como uma sai e o resto não é dentro o problema…

      Prof Marcelo Nascimento